1999 regal makes sound turning right - Buick Regal Forum : 2011 Buick Regal Forums
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 04-21-2017, 05:37 AM Thread Starter
Junior Member
 
Join Date: Sep 2016
Posts: 3
1999 regal makes sound turning right

Hello all first post here,long time buick owner. This problem has me stumped,the car is making a metallic noise whenever the wheel is turned to the right it sounds like a rotating noise and the car has to be moving and it sounds like its coming from the front but I can not tell if it is right or left . It does not make it up on jack stands the suspension has to be loaded. It reminds you of the dust shields hitting the rotors but there not trust me I have had the wheels off this car 50 times I think the studs are getting worn out. What I did do was replace the left bearing/hub first but that was not it then I replaced the right one and of course that was not it either.My next guess is the axles ? At this point my troubleshooting is getting expensive. Any ideas? Thanks in advance. By the way it is a 1999 Regal LSE 130k
jackadam is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Buick Regal Forum : 2011 Buick Regal Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome