Cruise Control no longer working - Buick Regal Forum : 2011 Buick Regal Forums
 
LinkBack Thread Tools
post #1 of 15 (permalink) Old 09-08-2014, 01:51 PM Thread Starter
Junior Member
 
Join Date: Jul 2014
Location: Vancouver, BC, Canada
Posts: 12
Cruise Control no longer working

I've recently noticed my cruise control is no longer working. When I flick the switch on, the white indicator lights up on the dash, but when I press down on the set/res dial to set the speed it doesn't set. Flicking the set/res switch up or down no longer has any effect. The radio control bottoms on the right side of my steering wheels still work properly.

Anyone have any fix suggestions before I bring it in to get serviced?

I looked in the manual for the fuse layouts but none seem to be for the cruise control specifically. I may go in and manually remove and inspect each fuse individually.

Last week I had 2 recall services done for my oil life and signal indictor as well as getting a new battery installed. I'm not sure if these changes are directly related to my new problem or not, but I did notice these changes (and a separate shift lock release issue) after the service was performed.

Thanks in advance for any suggestions.

Last edited by Kolbuc; 09-15-2014 at 02:30 AM.
Kolbuc is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 09-08-2014, 02:15 PM
Senior Member
 
Buick Customer Service's Avatar
 
Join Date: Jun 2010
Posts: 157
Sorry to hear you're now experiencing trouble with the cruise control, Kolbuc. If you'd like to provide us with the last 8 digits of your VIN we can check for any service announcements associated with this issue. However, if there are none to reference the dealership would be the best next step. Please let us know if we can be of assistance, or if we can connect you with a representative from GM Canada that can best assist.

Amber N.
Buick Customer Care
Buick Customer Service is offline  
post #3 of 15 (permalink) Old 09-10-2014, 03:48 AM
Junior Member
 
Join Date: Jun 2014
Location: Texas
Posts: 19
HEY Kolbuc I too had my battery replaced due to a dead cell and the signal indicator replaced per recall and my cruise control no longer works!!!! It lights up as you said and the other wheel controls work. My shifter lock was smooth as butter but after the warranty service it sticks!!!! I have an appt on the 16th to have it looked at again. Im so glad to see Im not making this stuff up.
adaboy is offline  
 
post #4 of 15 (permalink) Old 09-14-2014, 11:21 AM
Junior Member
 
Join Date: Aug 2014
Location: Ohio
Posts: 7
Thought I was crazy (or getting ripped off by the dealer)! Just took delivery of a 2011 Regal and put her in for some cleanup items and they did the "Rear Signal Lamp Not Working" recall fix and now I have no engage on the Cruise Control and have to put the brake pedal fully to the stop to get the shifter out of park. Already scheduled for service tomorrow - I'll update...
Captainjohn is offline  
post #5 of 15 (permalink) Old 09-14-2014, 11:29 AM
Junior Member
 
Join Date: Aug 2014
Location: Ohio
Posts: 7
Amber - my last 8 are: B1011800
Captainjohn is offline  
post #6 of 15 (permalink) Old 09-15-2014, 02:23 AM Thread Starter
Junior Member
 
Join Date: Jul 2014
Location: Vancouver, BC, Canada
Posts: 12
Quote:
Originally Posted by Buick Customer Service View Post
Sorry to hear you're now experiencing trouble with the cruise control, Kolbuc. If you'd like to provide us with the last 8 digits of your VIN we can check for any service announcements associated with this issue. However, if there are none to reference the dealership would be the best next step. Please let us know if we can be of assistance, or if we can connect you with a representative from GM Canada that can best assist.

Amber N.
Buick Customer Care
Hi Amber,

The last 8 digits of my VIN are B1003953
Kolbuc is offline  
post #7 of 15 (permalink) Old 09-15-2014, 11:29 AM
Senior Member
 
Buick Customer Service's Avatar
 
Join Date: Jun 2010
Posts: 157
Quote:
Originally Posted by Kolbuc View Post
Hi Amber,

The last 8 digits of my VIN are B1003953
Thank you for providing this information, Kolbuc. We will be sending you a private message to further discuss your concern. We hope to hear back from you soon!

Kristen A. (Assisting)
Buick Customer Care
Buick Customer Service is offline  
post #8 of 15 (permalink) Old 09-15-2014, 11:37 AM
Senior Member
 
Buick Customer Service's Avatar
 
Join Date: Jun 2010
Posts: 157
Quote:
Originally Posted by Captainjohn View Post
Amber - my last 8 are: B1011800
Hi Captainjohn,

We will be sending you a private message as well in regard to your concern. We look forward to looking further into this for you.

Kristen A. (Assisting)
Buick Customer Care
Buick Customer Service is offline  
post #9 of 15 (permalink) Old 09-16-2014, 06:55 PM
Junior Member
 
Join Date: Aug 2014
Location: Ohio
Posts: 7
Thanks to the whole crew at Jake Sweeney Chevrolet! They say they "relearned [the] brake pedal position sensor." The shifter and cruise control are now working properly again.
Captainjohn is offline  
post #10 of 15 (permalink) Old 09-16-2014, 07:15 PM
Senior Member
 
Buick Customer Service's Avatar
 
Join Date: Jun 2010
Posts: 157
Quote:
Originally Posted by Captainjohn View Post
Thanks to the whole crew at Jake Sweeney Chevrolet! They say they "relearned [the] brake pedal position sensor." The shifter and cruise control are now working properly again.
This is great news, Captainjohn! We're very pleased to hear Jake Sweeney Chevrolet was able to address the issues with your brake pedal sensor and cruise control. Please let us know if you're interested in sending a formal dealership compliment.

Best,
Amber N.
Buick Customer Care
Buick Customer Service is offline  
post #11 of 15 (permalink) Old 09-28-2014, 06:09 AM
Junior Member
 
Join Date: Jun 2014
Location: Texas
Posts: 19
Shifter is smooth again and cruise control working!! It was the break sensor had to "re-learn".
adaboy is offline  
post #12 of 15 (permalink) Old 10-01-2014, 05:50 PM Thread Starter
Junior Member
 
Join Date: Jul 2014
Location: Vancouver, BC, Canada
Posts: 12
By providing my dealership these conversations and my research from this forum, I was able to convince them to perform the break sensor re-learning and cruise control recalibration at no-charge.

You would think Buick dealerships would scan the odb2 codes before and after service recalls and/or Buick would have these re-learn/recalibration steps built in to the step-by-step process when performing these recall services. I hope they iron out these wrinkles for other Buick owners as this was not a pleasant experience.

Thanks for the everyone's responses, without them I'd still be a frustrated Bruick owner with a broken vehicle.
Kolbuc is offline  
post #13 of 15 (permalink) Old 03-04-2015, 06:50 PM
Junior Member
 
Join Date: Mar 2015
Location: Grove City , PA
Posts: 1
Hi, I am new to the forum so I hope I am doing this right. ( computer dumb ) I just had my regal in for the 12212 turn signal recall on wed. 2/25/15. Lots of snow here so I didn't need to use the cruise control until sunday. I notice the brake has to be pushed in far, to get out of park , and the cruise does not work. I called the dealership, they are suppose to get me in to check it out on Friday 3/6/15. I told them about the forum and I got the feeling, they think I don't know what I am talking about . The last 8 digits of my vin # B1066744 . I have just recently heard some horror stories about this dealership fixing and charging for repairs that aren't needed. I didn't have any trouble with the car before the recall procedure now I do. I fear I will get charged for them to check this out. If I do , is there any one or place I should contact if this happens. I would rather not list the dealership unless absolutely necessary. Sorry for all whining., but I would appreciate any advice. Thanks so much
Jim Pearce is offline  
post #14 of 15 (permalink) Old 03-10-2015, 05:48 PM
Senior Member
 
Buick Customer Service's Avatar
 
Join Date: Jun 2010
Posts: 157
Hi Jim Pearce,

I’m very sorry to hear that you are experiencing this with your cruise control and your brakes on your Regal. However, I’m glad to see that you were able to get in touch with your dealership regarding these concerns. Was your dealership able to help you find a resolution to these concerns? Definitely do keep us updated. You are always welcome to send us a private message with any questions.

Kind regards,

Shane M.
Buick Customer Care
Buick Customer Service is offline  
post #15 of 15 (permalink) Old 09-04-2015, 08:44 AM
Junior Member
 
Join Date: Sep 2015
Location: PA
Posts: 1
First my cruise control stopped working and now my brake lights stopped working but my turn signals work.....any help?
Davey is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Buick Regal Forum : 2011 Buick Regal Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome