Radio Reception Poor - Buick Regal Forum : 2011 Buick Regal Forums
 
LinkBack Thread Tools
post #1 of 9 (permalink) Old 02-25-2013, 08:56 AM Thread Starter
Junior Member
 
Join Date: Feb 2013
Location: Indiana
Posts: 10
Radio Reception Poor

Hello,
I'm new here, from Fort Wayne, IN.
I purchased my 2011 Regal Turbo used with 26K on it.
I love the car, but I'm having trouble with radio reception.
I drive back and forth to Lansing, MI quite often, about a 2 hr drive.
The stations that I listen to, cut out about 80 miles sooner than they used to.
Does anyone else have problems with their radio reception?
Is there a software upgrade available to improve this problem?
Or does anyone have an aftermarket solution - antennae booster?

Thank you for any help you can offer.
Sillemik68 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 02-25-2013, 10:49 AM
Senior Member
 
Buick Customer Service's Avatar
 
Join Date: Jun 2010
Posts: 157
Quote:
Originally Posted by Sillemik68 View Post
Hello,
I'm new here, from Fort Wayne, IN.
I purchased my 2011 Regal Turbo used with 26K on it.
I love the car, but I'm having trouble with radio reception.
I drive back and forth to Lansing, MI quite often, about a 2 hr drive.
The stations that I listen to, cut out about 80 miles sooner than they used to.
Does anyone else have problems with their radio reception?
Is there a software upgrade available to improve this problem?
Or does anyone have an aftermarket solution - antennae booster?

Thank you for any help you can offer.
Hi Sillemik68,
I'd be happy to look into this issue for you.. If you PM me your VIN and mileage I can see if you are still under any applicable warranties or if I can find any relevant information for you thru my resources.

Thank you,
Sara
Buick Customer Service
Buick Customer Service is offline  
post #3 of 9 (permalink) Old 08-26-2014, 06:59 PM
Member
 
Hitman1970's Avatar
 
Join Date: Oct 2012
Location: Huntsville, AL
Posts: 81
I have a bought new 2012 Buick Regal Turbo Premium I Group with 15,550 miles on the odometers. One month shy of two years old. Still in the bumper to bumper warranty coverage.

While driving back from work today I tried to tune in 103.5 WTOP radio which you can get from Baltimore to DC no problem. I got nothing on my FM radio. Hitting the menu button the channels "updated" and found nothing. Also my AM radio can only be heard at a whisper level on volume 28 or higher. My XM, CD, and USB inputs all work normally. Not a huge problem but I want to get it fixed.

I also have the turning signal burnout software recall to do.
Hitman1970 is offline  
 
post #4 of 9 (permalink) Old 08-26-2014, 11:21 PM
Senior Member
 
Buick Customer Service's Avatar
 
Join Date: Jun 2010
Posts: 157
Hi Hitman1970,

Sorry you're having trouble with the radio reception. We'd be glad to connect with your dealership on your behalf and document your concerns within our system. Please send me a private message and include your contact information and VIN. We hope to hear from you!

Andraya (assisting Jessica)
Buick Customer Care
Buick Customer Service is offline  
post #5 of 9 (permalink) Old 09-10-2014, 07:59 PM
jak
Junior Member
 
Join Date: Apr 2014
Location: Delaware
Posts: 1
radio reception

I am also having problems with radio reception on my 2011 Buick Regal. I bought it used april 2014 with this problem. I didn't listen to the radio during the test drive ,trying to listen to everything else. My last thought was that there could be something wrong with the stereo. After i bought it and was driving it home i found the radio muffled and the sound dropping out on the radio. The first service they performed a cal on the stereo which fixed the muffled sound of everything. But the reception randomly dropping continued. I've had it to a dealer 4 times and they can't figure out the problem. They've replaced the antennae amplifier and verified some of the wiring to the antennae but didn't fix it. Sillemik68, did they resolve your problem and if so what did they fix.
jak is offline  
post #6 of 9 (permalink) Old 01-25-2015, 08:46 AM
Junior Member
 
Join Date: Sep 2012
Location: Detroit
Posts: 23
I have the same issue with my 2011 Regal T06. First they replaced the amplifier for the loudness issue... The audio would go up and down all the time. The reception sucks in that car. It's the first car I ever owned to experience this issue. The signal just drops and the radio doesn't work at all. I've had it at the dealership many times for radio/audio issues and they still remain.

The left front door speaker has distortion coming out of if and cutting out. They have replaced the speaker and wiring harness in the door but the issue remains. It's very frustrating when you take the day off to show them the issue and the speaker/sound system play fine and when you take the car and start driving home it does it again. It will do it on all source material, CD, radio, XM and cell phone call. I even went as far as recording the distortion on my iPhone to play it back but they don't want to hear it and say we will take a look at it. I've had it at the dealership three times for the speaker issue and still no fix. I think I will take it to another dealership just to see if maybe they can fix it.

Steve
audiophile1970 is offline  
post #7 of 9 (permalink) Old 01-25-2015, 10:27 PM
Member
 
Hitman1970's Avatar
 
Join Date: Oct 2012
Location: Huntsville, AL
Posts: 81
After replacing an antenna amplifier which did not fix my radio the dealership had my car 10 days ordering and getting a completely new radio to solve my issue a few weeks ago. The radio debacle was almost a five month ordeal. Only AM/FM but still a pain.
Hitman1970 is offline  
post #8 of 9 (permalink) Old 01-26-2015, 10:45 AM
Junior Member
 
Join Date: Sep 2012
Location: Detroit
Posts: 23
Hitman1970,

After they replaced the radio did that solve your AM/FM signal issue?

Steve
audiophile1970 is offline  
post #9 of 9 (permalink) Old 01-26-2015, 06:21 PM
Member
 
Hitman1970's Avatar
 
Join Date: Oct 2012
Location: Huntsville, AL
Posts: 81
Quote:
Originally Posted by audiophile1970 View Post
Hitman1970,

After they replaced the radio did that solve your AM/FM signal issue?

Steve
It did. Radio reception is now perfect again.
Hitman1970 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Buick Regal Forum : 2011 Buick Regal Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome