Pillar Pod Gauges - Buick Regal Forum : 2011 Buick Regal Forums
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 07-13-2013, 07:12 PM Thread Starter
Junior Member
 
Join Date: Jul 2013
Location: Tucson AZ
Posts: 2
Pillar Pod Gauges

I would like to add a boost gauge to the left A pillar. Can not find anything anywhere, a local shop said they could fiberglass one in and re cover it. As soon as I do all of that, a pillar replacement with a pod will prob pop up on the market. Has anyone else wanted to do the same, or found anything?

Thanks.
2012_GS is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 04-21-2015, 12:22 AM
Junior Member
 
Join Date: Nov 2014
Location: MN
Posts: 22
Waiting patiently...
S.O.G is offline  
post #3 of 3 (permalink) Old 09-12-2015, 04:09 PM
Junior Member
 
Join Date: Sep 2015
Location: Cleveland Ohio
Posts: 1
I bought and installed this one. Nice custom fit. Great design from P3cars.com a little pricy but well worth it considering the easy install
Attached Images
File Type: jpg IMG_20150810_161457:nopm:_1442088442300.jpg (98.0 KB, 31 views)
Jcruz6069 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Buick Regal Forum : 2011 Buick Regal Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome