Need help!!!! - Buick Regal Forum : 2011 Buick Regal Forums
 
LinkBack Thread Tools
post #1 of 8 (permalink) Old 07-27-2012, 09:30 AM Thread Starter
Junior Member
 
Join Date: Apr 2012
Location: Troy MI
Posts: 12
Need help!!!!

Hey Guys so recently, the bluetooth and compass on the the 2011 Buick Regal that i have does not work. The Compass has two dashed lines which i saw in manual means that it needs servicing. Also the bluetooth says its not able to connect, or not available as well. So its starting to worry me because, i had this problem before. What i did was went to the dealer to get the new update for the navigation and that fixed everything. As i talked to the dealer and its not a software issue, since the software is up to date, and its nothing that they can do since the car is not under warranty due to an accident. So last time i paid the 120$ for the service charge to get the new software on the car, but now its not going to be a software issue.

My question is, does anybody think that the ONSTAR has any reference to the bluetooth or compass? Are they connected in anyway? Since my ONSTAR is inactive, do you think that ONSTAR shut off those connections considering the vehicle is inactive? I say this because it worked when i first got the car, and it stopped, and then i got the software update and it worked and now after a month it stopped again. The dealer said they pinged the ONSTAR modules and they had no ping back, so it wasn't able to communicate with it. Somebody please let me know, and please email me at [email protected]

Thank you all SO MUCH!!
alexgradianu1 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 07-30-2012, 08:41 AM
Member
 
Join Date: Oct 2011
Location: Mesquite, TX
Posts: 97
Send a message via Yahoo to bpwilmoth
I don't think an in-active OnStar account would keep the compass from working. Have you tried to calibrate the compass? I had an 07 GP GXP and had to re-calibrate the compass a few times.

Bryan Wilmoth
2011 Regal CXL Turbo
Trifecta Tune
T05, 20% Rear 30% Front Tint
MTX Re-Q Processor with Kenwood KAC 7204 Amp powering a Sundown Audio E-10 Subwoofer in a 1.1 cu/ft vented enclosure
bpwilmoth is offline  
post #3 of 8 (permalink) Old 07-30-2012, 02:47 PM Thread Starter
Junior Member
 
Join Date: Apr 2012
Location: Troy MI
Posts: 12
Calibration

I thought it said in the manual that the compass calibrates itself once you ride around, there is no other way for me to calibrate it. I just dont understand why the bluetooth and compass would both shut off at the same time....? it confuses me.
alexgradianu1 is offline  
 
post #4 of 8 (permalink) Old 08-03-2012, 04:05 PM
Member
 
cozbyrt's Avatar
 
Join Date: Feb 2011
Location: Van,TX
Posts: 97
The dealer said the warranty is no longer active because the car was in an accident? That doesn't sound right. Is there another dealer you can take it to?

2011 Buick Regal T-05
cozbyrt is offline  
post #5 of 8 (permalink) Old 08-14-2012, 09:11 AM Thread Starter
Junior Member
 
Join Date: Apr 2012
Location: Troy MI
Posts: 12
Regal

Well the car was in a salvage accident, so its got a salvage title, and that is why they say its a branded title so its not under warranty, but whatever, so i started to take the car apart and see what is wrong.

And i have taken it apart, and i found out that the bluetooth onStar Antenna chip its a wireless interface antenna was bad, since i went from another regal that we have, and swapped it out. So the compass and all that started working once i put the new chip in.

I found them on Amazon they are for around $25. Part number: ACDelco 15938939

The point being is, that after two weeks of having the new chip there, it is now not working again, i ordered another chip to replace it, but how long am i going to have to do this, are these chips all bad? (i doubt it) or is there something that is damaging my antenna chips. Does anybody know? I wish i could take my car into service but they charge me so much!!!!
alexgradianu1 is offline  
post #6 of 8 (permalink) Old 08-18-2012, 09:24 PM
Super Moderator
 
Join Date: Oct 2011
Location: Michigan
Posts: 299
sounds like there may be a short. do you know where the car was hit? maybe trace the wiring?




James -
2012 Chevy Express Cargo
2013 Chevy Volt
thestepchild is offline  
post #7 of 8 (permalink) Old 08-21-2012, 06:49 PM Thread Starter
Junior Member
 
Join Date: Apr 2012
Location: Troy MI
Posts: 12
Hit

in the door, but everything was replaced, i dont understand, it works fine now, and the cards were not broken, i put the old one in that wasn't working after i took everything apart and the cards work again. I dont understand.
alexgradianu1 is offline  
post #8 of 8 (permalink) Old 08-22-2012, 05:17 PM
Junior Member
 
Join Date: Oct 2011
Location: Alexandria, VA
Posts: 6
I just had the same thing happen to my car. Thankfully it was under warranty becuase they had to replace the entire OnStar system. It would have cost me over $1000 out of pocket. I hope your case isn't as severe as mine was, but it sounds like it. It started out the same way. My compass stopped working. Then the phone wouldn't pair Then the buttons on the mirror went dead. It took them several days to fix it. Again, good luck, but it doesn't sound promising.
JMregal is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Buick Regal Forum : 2011 Buick Regal Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome