Cruise Control no longer working - Page 2 - Buick Regal Forum : 2011 Buick Regal Forums
Reply
 
LinkBack Thread Tools
post #16 of 16 (permalink) Old 02-04-2020, 11:11 AM
Junior Member
 
Join Date: Feb 2020
Posts: 1
multiple problems with 2011 Regal

I am having all the bad luck of others all in my own 2011 Regal.

1. In cold weather my car will have the reduced engine power come on. I pull over wait 20 seconds and then turn on, will run for awhile but will happen again. Happens at high speed and at low speed.

2. Heated seats do not work. I push button and the indicator lights up but nothing happens and it shuts off.

3. Cruise control does not work. The indicator light on dashboard lights up when I hit the cruise control on steering wheel, but it never engages the speed.

Is there a recall on any of these problems? Sounds like a lot of Buick owners are having the same problems.
Ryecoach is offline  
Sponsored Links
Advertisement
 
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Buick Regal Forum : 2011 Buick Regal Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome