Buick Regal Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hey Guys,

Does anyone with a '12 GS or other sub-model have an issue with a belt squeal if the car is started with the a/c on?
 

·
Registered
Joined
·
157 Posts
Hey Guys,

Does anyone with a '12 GS or other sub-model have an issue with a belt squeal if the car is started with the a/c on?
Hi TriniDemon,

I’m sorry to hear that you are experiencing a belt squeal with your GS when it is started with the A/C on. Though you are looking for feedback from the forum community, were you able to get in touch with your dealership regarding this concern? I would be more than happy to look into this concern further and get in touch with them on your behalf. If interested, please feel free to send me a private message including your VIN, mileage, full contact info and the name of your preferred local dealer. Hope to hear from you soon!

Best regards,

Shane M.
Buick Customer Care
 

·
Registered
Joined
·
81 Posts
Tensioner and belt happened to my '11 Regal Turbo at 13,000 miles. I wonder if it will make it to 26,000 miles before needing it again. My car currently has 21,000 miles on it.
 

·
Registered
Joined
·
3 Posts
I just had the same issue with my 2011 Buick Regal and it was the tensioner and belt. My car would not make the noise while parked but the minute i put it in drive and give it gas, it squealed very loud. It was fixed and I have not had the problem again.
 
1 - 6 of 6 Posts
Top