Buick Regal Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 · (Edited)
I've recently noticed my cruise control is no longer working. When I flick the switch on, the white indicator lights up on the dash, but when I press down on the set/res dial to set the speed it doesn't set. Flicking the set/res switch up or down no longer has any effect. The radio control bottoms on the right side of my steering wheels still work properly.

Anyone have any fix suggestions before I bring it in to get serviced?

I looked in the manual for the fuse layouts but none seem to be for the cruise control specifically. I may go in and manually remove and inspect each fuse individually.

Last week I had 2 recall services done for my oil life and signal indictor as well as getting a new battery installed. I'm not sure if these changes are directly related to my new problem or not, but I did notice these changes (and a separate shift lock release issue) after the service was performed.

Thanks in advance for any suggestions.
 

·
Registered
Joined
·
157 Posts
Sorry to hear you're now experiencing trouble with the cruise control, Kolbuc. If you'd like to provide us with the last 8 digits of your VIN we can check for any service announcements associated with this issue. However, if there are none to reference the dealership would be the best next step. Please let us know if we can be of assistance, or if we can connect you with a representative from GM Canada that can best assist.

Amber N.
Buick Customer Care
 

·
Registered
Joined
·
27 Posts
HEY Kolbuc I too had my battery replaced due to a dead cell and the signal indicator replaced per recall and my cruise control no longer works!!!! It lights up as you said and the other wheel controls work. My shifter lock was smooth as butter but after the warranty service it sticks!!!! I have an appt on the 16th to have it looked at again. Im so glad to see Im not making this stuff up.
 

·
Registered
Joined
·
7 Posts
Thought I was crazy (or getting ripped off by the dealer)! Just took delivery of a 2011 Regal and put her in for some cleanup items and they did the "Rear Signal Lamp Not Working" recall fix and now I have no engage on the Cruise Control and have to put the brake pedal fully to the stop to get the shifter out of park. Already scheduled for service tomorrow - I'll update...
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #6 ·
Sorry to hear you're now experiencing trouble with the cruise control, Kolbuc. If you'd like to provide us with the last 8 digits of your VIN we can check for any service announcements associated with this issue. However, if there are none to reference the dealership would be the best next step. Please let us know if we can be of assistance, or if we can connect you with a representative from GM Canada that can best assist.

Amber N.
Buick Customer Care
Hi Amber,

The last 8 digits of my VIN are B1003953
 

·
Registered
Joined
·
7 Posts
Thanks to the whole crew at Jake Sweeney Chevrolet! They say they "relearned [the] brake pedal position sensor." The shifter and cruise control are now working properly again.
 

·
Registered
Joined
·
157 Posts
Thanks to the whole crew at Jake Sweeney Chevrolet! They say they "relearned [the] brake pedal position sensor." The shifter and cruise control are now working properly again.
This is great news, Captainjohn! We're very pleased to hear Jake Sweeney Chevrolet was able to address the issues with your brake pedal sensor and cruise control. Please let us know if you're interested in sending a formal dealership compliment.

Best,
Amber N.
Buick Customer Care
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #12 ·
By providing my dealership these conversations and my research from this forum, I was able to convince them to perform the break sensor re-learning and cruise control recalibration at no-charge.

You would think Buick dealerships would scan the odb2 codes before and after service recalls and/or Buick would have these re-learn/recalibration steps built in to the step-by-step process when performing these recall services. I hope they iron out these wrinkles for other Buick owners as this was not a pleasant experience.

Thanks for the everyone's responses, without them I'd still be a frustrated Bruick owner with a broken vehicle.
 

·
Registered
Joined
·
1 Posts
Hi, I am new to the forum so I hope I am doing this right. ( computer dumb ) I just had my regal in for the 12212 turn signal recall on wed. 2/25/15. Lots of snow here so I didn't need to use the cruise control until sunday. I notice the brake has to be pushed in far, to get out of park , and the cruise does not work. I called the dealership, they are suppose to get me in to check it out on Friday 3/6/15. I told them about the forum and I got the feeling, they think I don't know what I am talking about . The last 8 digits of my vin # B1066744 . I have just recently heard some horror stories about this dealership fixing and charging for repairs that aren't needed. I didn't have any trouble with the car before the recall procedure now I do. I fear I will get charged for them to check this out. If I do , is there any one or place I should contact if this happens. I would rather not list the dealership unless absolutely necessary. Sorry for all whining., but I would appreciate any advice. Thanks so much
 

·
Registered
Joined
·
157 Posts
Hi Jim Pearce,

I’m very sorry to hear that you are experiencing this with your cruise control and your brakes on your Regal. However, I’m glad to see that you were able to get in touch with your dealership regarding these concerns. Was your dealership able to help you find a resolution to these concerns? Definitely do keep us updated. You are always welcome to send us a private message with any questions.

Kind regards,

Shane M.
Buick Customer Care
 

·
Registered
Joined
·
1 Posts
First my cruise control stopped working and now my brake lights stopped working but my turn signals work.....any help?
 

·
Registered
Joined
·
1 Posts
multiple problems with 2011 Regal

I am having all the bad luck of others all in my own 2011 Regal.

1. In cold weather my car will have the reduced engine power come on. I pull over wait 20 seconds and then turn on, will run for awhile but will happen again. Happens at high speed and at low speed.

2. Heated seats do not work. I push button and the indicator lights up but nothing happens and it shuts off.

3. Cruise control does not work. The indicator light on dashboard lights up when I hit the cruise control on steering wheel, but it never engages the speed.

Is there a recall on any of these problems? Sounds like a lot of Buick owners are having the same problems.
 
1 - 16 of 16 Posts
Top