Buick Regal Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Hello All,

Got the Regal back today after 4 days in the shop. The 2.4 L's have a lower and upper portion to the block assembly....sealed together with good ol Permatex black sealant. I guess only some time will tell if the sealant cured correctly. The engine light was a disloged vacuum line....don't know how that occured, but an easy fix.

Bob the Service Advisor at Pellegrino Buick was very accomidating through the entire process, and I thank him for his help. I would also like to thank Matt and Sara from Buick Customer Service for their attention and concern with this issue.

Hopefully, I only have to pay Bob a visit for routine maintanance over the next 2 years.....he probably feels the same way too! :D

Scott
 

·
Registered
Joined
·
157 Posts
Hello All,

Got the Regal back today after 4 days in the shop. The 2.4 L's have a lower and upper portion to the block assembly....sealed together with good ol Permatex black sealant. I guess only some time will tell if the sealant cured correctly. The engine light was a disloged vacuum line....don't know how that occured, but an easy fix.

Bob the Service Advisor at Pellegrino Buick was very accomidating through the entire process, and I thank him for his help. I would also like to thank Matt and Sara from Buick Customer Service for their attention and concern with this issue.

Hopefully, I only have to pay Bob a visit for routine maintanance over the next 2 years.....he probably feels the same way too! :D

Scott
You're welcome and thank you for the compliment. I hope as well that this issue is taken care of for you. If anything like this happens again, please let us know. Regards.

Matt,

Buick Customer Assistance
 
1 - 4 of 4 Posts
Top