Buick Regal Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
Every once in awhile when I start my 2011 Regal CXL, there are 2 sets of dashed lines on the display screen upper middle, which is usually blank. When this happens, the seat heaters will go on for roughly 2 seconds, then shut off. You can hear an audible click when the shut down. Other times they will not come on at all. Last night it happened so I made a video. In this instance they would come on and shut off. The problem seems to go away after turning the car on and off a few times, so something is resetting. Anyone else ever have this? I am posting a link to the video, hopefully people can view it.

https://www.facebook.com/photo.php?v=770641042963907&l=8178501101680910901
 

·
Registered
Joined
·
157 Posts
I did check with the dealer, they couldn't recreate it, so no help. Now the car's engine failed when the timing chain broke, so the seat heat issue seems pretty small.
Are repairs already underway for the engine repair? It sounds like you may still be within the Powertrain warranty by time. Has the dealer already discussed repair options with you? Please let us know if there's anything we can do to assist with this situation.

Amber N.
Buick Customer Care
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #6 ·
Yes, repairs are underway at the dealer, Richardson Motors in Dubuque, Iowa. It was a certified car so is being covered by warranty. I am very curious to get their take on what caused it and the odds of further trouble.
 

·
Registered
Joined
·
157 Posts
Thank you for the update. We are happy to hear this repair will be covered by your warranty. Please let us know if you have any additional questions or concerns.

Jessica
Buick Customer Care

Yes, repairs are underway at the dealer, Richardson Motors in Dubuque, Iowa. It was a certified car so is being covered by warranty. I am very curious to get their take on what caused it and the odds of further trouble.
 
1 - 7 of 7 Posts
Top